华为交换机配置端口实例

配置华为交换机端口为access和trunk口常见的步骤及命令。

一、连接交换机

连接console线,端口号在设备管理器查看,波特率9600,数据位8,停止位1,奇偶校验和流控制为无。

华为交换机配置端口实例
Xshell中配置截图示例

二、调试交换机

1. 查看交换机配置

在控制台键入回车和密码连接到交换机。

进入交换机命令行后,输入dis cu查看交换机当前配置,下面是输出配置的一部分,可以看到有GigabitEthernet0/0/1、XGigabitEthernet0/0/1等6个接口。

<huawei>dis cu
......<省略一部分内容>......
#
interface GigabitEthernet0/0/1  千兆端口(1G),一般简称GE0/0/1
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
interface GigabitEthernet0/0/4
#
interface XGigabitEthernet0/0/1  万兆端口(10G),一般简称XGE0/0/1
#
interface XGigabitEthernet0/0/2

2. 配置端口

  • 假如此时有服务器、电脑等普通上网设备需要连接到交换机3口和vlan10,则需要先将GigabitEthernet0/0/3端口配置为access,再端口的vlan为10,此时键入以下命令来配置:
<huawei>sys  //进入到管理员模式
[huawei]vlan 10  //设置一个新的vlan,为10(假如在dis cu中看到了vlan 10,那就不需要执行这一步)
[huawei-vlan10]q  //退出vlan配置,回到之前的sys管理员模式
[huawei]int GigabitEthernet0/0/3  //进入GE0/0/3端口
[huawei-GigabitEthernet0/0/3]port link-type access  //将GE0/0/3口配置为access端口
[huawei-GigabitEthernet0/0/3]port default vlan 10  //将GE0/0/3口的vlan配置为10
[huawei-GigabitEthernet0/0/3]q  //退出GE0/0/3端口配置,回到之前的sys管理员模式
  • 假如此时需要将GigabitEthernet0/0/1、GigabitEthernet0/0/2、GigabitEthernet0/0/3这3个端口配置为access端口和vlan10,则使用range来批量配置:
<huawei>sys  //进入到管理员模式
[huawei]vlan 10  //设置一个新的vlan,为10(假如在dis cu中看到了vlan 10,那就不需要执行这一步)
[huawei-vlan10]q  //退出vlan配置,回到之前的sys管理员模式
[huawei]int range GigabitEthernet0/0/1 to GigabitEthernet0/0/3  //批量管理GE0/0/1-GE0/0/3(不同交换机range用法不太一样,请自行百度)
[huawei-port-group]port link-type access  //将GE0/0/1-GE0/0/3口批量配置为access端口
[huawei-port-group]port default vlan 10  //将GE0/0/1-GE0/0/3口的vlan批量配置为10
[huawei-port-group]q  //退出range组配置,回到之前的sys管理员模式
  • 还记得之前使用dis cu命令时,显示还有XGigabitEthernet0/0/1这样的万兆端口吗?这些端口一般是用来连接别的交换机的,所以这个端口需要配置为trunk模式。将端口改成trunk模式的步骤和access基本一样,下面为配置XGE0/0/1口为trunk口并放通vlan10、vlan20的示例:
<huawei>sys  //进入到管理员模式
[huawei]int XGigabitEthernet0/0/1  //进入XGE0/0/1端口
[huawei-XGigabitEthernet0/0/1]port link-type trunk  //将XGE0/0/1口配置为trunk端口
[huawei-XGigabitEthernet0/0/1]port trunk allow-pass vlan 10 20  //允许XGE0/0/1口通过vlan10和20
[huawei-XGigabitEthernet0/0/1]q  //退出XGE0/0/1端口配置,回到之前的sys管理员模式

3. 保存配置

最后,配置完成交换机后,别忘记保存配置,不然断电重启后所有为保存的配置都会丢失。使用下面命令来保存:

[huawei]q  退出sys管理员模式
<huawei>sa  保存配置
The current configuration will be written to the device.
Are you sure to continue?[Y/N]y  //接着按y并回车确认
Info: Please input the file name ( *.cfg, *.zip ) [vrpcfg.zip]:  //再次回车来使用默认配置名保存
Now saving the current configuration to the slot 0.  //提示正在保存
Save the configuration successfully.  //提示保存成功
网络

WordPress自定义登录页面 美化登录界面

2022-1-1 21:11:37

技术脚本

js报错TypeError: Cannot find function match in object

2021-9-24 8:36:46